SwipeSimple Swift B250 Card Reader Error: The card reader is not working properly, Please contact your vendor for a replacement

Last Updated: May 29, 2024

What's in this article?

Symptoms

  1. Using a B520 card reader
  2. Gets error The card reader is not working properly, Please contact your vendor for a replacement

Cause

There is a fatal error with the B250 card readers

Resolution

There is no fix known for the issue

This error only affects the B250 units. The B200 units are recommended to be used in the meantime until a fix for this can be found

The only difference in these units is the B200 does not accept tap pay, so if the business has a high volume of Apple/Samsung pay, this is not a viable option

Perform RMA according to Partner procedures and include the information about the B250s. 

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