Dejavoo Z6 Pinpad: Tap Function not Working

Dejavoo Z6 Pinpad: No longer Accepts Tap Function

Last Updated: May 31, 2024

What's in this article?

Symptoms:  Using Dejavoo Z6 PIN Pad with an attached terminal

Z6 PIN Pad will no longer take Tap (NFC) Cards

Cause

Faulty Contact Reader

Program error

Resolution(s)

Test Contact Reader

  1. Reboot PINpad and press red x button repeatedly until you see Program Manager
  2. Press 0
  3. Enter the Password 0106 and press the Green Enter button
  4. Enter 12 and press the Green Enter button
  5. Press 2, and put a contactless card on card terminal to test

If the Terminal does not beep there maybe an issue with the card reader.

If the card reader beeps, card reader is working

Delete/Reinstall pinpad app

  1. Configure terminal network
    1. If terminal is connected to wifi connect pinpad to the same wifi network
    2. If the terminal is connected via Ethernet remove Ethernet cable from terminal and connect directly to pinpad usb dongle
  2. ON PINPAD 
    On the main screen press the green OK button to get to the Core Menu
    • If the green OK button does not work try...
      • On Aura non-touch models press F1 for Core
      • On Aura Touch Models tap the 3 lines at the bottom of the screen
     
  3. Select Utilities
  4. **IF prompted** Enter the password 1234 and press the Green OK button
  5. Select Software Download
  6. Select delete app
  7. Confirm deletion
  8. PINpad will reboot to blank screen
  9. Tap the 3 bars at the bottom
  10. Enter the password 1234 and press the Green OK button
  11. Select Utilities
  12. Select Software Download
  13. Perform Full Download on PINpad to reinstall PINpad app
    Dejavoo: Full or Partial Download
    Public | Aug 18, 2025

    "

    All Downloads

    • Settle the batch before downloading
      • Failure to close the batch can result in lost transactions 
    • The File must be unlocked before it can be downloaded
    • When creating a File build request:
      • Provide merchant with case #
      • Provide merchant call-back information
      • Let the merchant know that file builds can take 24-48 hours
      • Have the merchant call you back at their Convenience to download the file
    • Once unlocked, the file will remain unlocked for 24 hours  

    STAX Terminals: If a site has STAX and is using FDO processing with Datawire a Full-download will break the Datawire connection, and require re-registration. Please consult a TR before doing a full download.

    1. Close batch on terminal
        Dejavoo: Settle an open batch     Internal  |  May 15, 2024  |   


    2. **If on a QD Terminal** Open the Aura App
    3. From the main screen Navigate press the green OK button to get to the Core Menu
      • If the green OK button does not work try...
        • On Aura non-touch models press F1 for Core
        • On Aura Touch Models tap the 3 lines at the bottom of the screen
    4. Press 4 for Utility
    5. Key in terminal password (1234) and press the green OK button.
    6. Press 2 for Software Download
    7. Press 1 for Connect
    8. On the Connect screen, select the appropriate method
      • 1 for Ethernet
      • 2 for Dial
      • 3 for WiFi
      • 4 for USB
    9. On the Select Type screen, select the type of download
      • 1 for Full
      • 2 for Partial
    10. If the terminals prompts to close batch, select Yes.
    11. On the Enter TPN screen, either confirm the existing TPN# or key in a new number. Press the green OK button to confirm.
    12. If terminal prompts to ""Apply Download?"", select Yes.
    13. If terminal prompts to ""Apply Updates?"", select Yes.
    14. Terminal will now display Connecting with a status bar or percentage. When the download completes, the terminal will boot back to the main screen.

    For Indeflex merchants: Make sure Edit Tip has been added to Favorites menu (for Restaurants using tips) after download

    Common Errors:

    • DOWNLOAD FAILED: Verify network connectivity. If using a phone line or WiFi, try connecting to ethernet.
    • If the download fails when using a Dial connection confirm no other device/phone is using the line and retry at least once
    • Make sure time and date are correct.
    • If the download fails when using a USB drive attempt to plug in the USB drive to a computer and verify the device can be read and there are files on the drive
    • USB requires a Micro USB A Male to USB A Female dongle in order to plug in the thumb drive into the terminal 
    • Rebooting the Terminal with a USB thumb drive plugged in will prompt for download.


    • ""Application Update Failed with Code 2"" - to clear this error follow the steps below:
      1. Clear the credit/debit application.
          Dejavoo: How to Delete Apps     Internal  |  May 15, 2024  |   



      2.  Reattempt a Full Download on the TPN.

    "



  14. Test tap function
  15. If tap function still doesn't work, perform an RMA
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